logo
Welcome Guest! To enable all features please Login. New Registrations are disabled.

Notification

Icon
Error

Options
Go to last post Go to first unread
Erwin  
#1 Posted : Thursday, November 5, 2009 11:01:10 AM(UTC)
Erwin

Rank: Administration

Reputation:

Groups: Moderators, Administration, Member
Joined: 10/8/2008(UTC)
Posts: 44

Request an extra IP-address at your hostingprovider for the webserver where your website is hosted.
Be sure to ask if your hostingprovider configures their firewall/routing to match the other IP-addresses (like: FTP,SMTP,HTTP,HTTPS on ports 20-21, 25, 80 & 443 )

Get an SSL certificate. (in The Netherlands you can use https://www.sslcertificaten.nl/ )
I used the last time MOBILE SSL from COMODO. (but it can be anyone, just be sure your customer knows the differences)
Follow the instructions to acquire the certificate. Be sure to put as much info of the customer (the website your implementing it for) in the request. This will be checked by the issuer, so it is important.

After you received the new IP-address, and the certificate, we are going to implement the certificate in the IIS.
When you are implementing the certificate, be sure to assign port 443 to the new IP-address (it's an internal IP-address (like 192.168.30.25 which is mapped by your hostingprovider to the new external IP-Address)
(This can be done afterwards also like this: IIS website> Properties > Web Site > Advanced at IPAddress-part > SSL > 443 > Edit)

Stop and start the website in IIS. (to be sure SSL works on the correct port)

Change your hostfile at your local PC to the new IP address.

The website is still reachable for other people, because port 80 is listening to "All unassigned IP-addresses"

Check on your PC with the changed hostfile if the website is reachable on https://www.yourdomain.com

If you get an error like "This page contains both secure and nonsecure items", it means you have absolute paths to images or objects which go to http://www.yourdomain.com. To avoid this, make everything on the page relative (like <img src="/images/image.jpg"> in stead of <img src="http://www.yourdomain.com/images/image.jpg"> )

It everything works, change the A-record of the domain to the new IP address so everybody in the world can use the SSL/https.

Don't forget to put your hostfile back to the normal state to check if it works.

Get a cup of coffee :-)

Wanna join the discussion?! Login to your Sienn Forum forum account. New Registrations are disabled.

Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.